This is not an issue with the Geek Pulse. The built-in Flash plugin in Chrome conflicts with the Adobe version when both are installed. One of the plugins will need to be disabled.

In Chrome enter the following address into the location bar:




Click the Details link on the right side of the page and find the Shockwave Flash Player plugins. Disable one of the plugins, close Chrome, and reload the web content that would not play correctly to test.


If there are still issues, re-enable the Flash plugin and disable the other to retest.

Edited: this will no longer apply to the newer version of Chrome. It is is known Error and will be addressed. (11/16/2015)