Start a new topic

Geek Pulse XfI will not initialise with Audirvana

I have a geek Pulse Xfi which seems to have developed a problem. Initially i thought this may be due to an OS upgrade to El Capitan. However I have spent the day reinstalling Yosemite from scratch (which was stable with the pulse) and still have the same problem. I have also upgraded to Audirvana 2+ and this has not solved the problem either. 

The pulse starts up ok and is recognised by both the Mac and Audirvana. It is visible in the system settings and i have selected it as the output. I have also checked that it is visible in the Midi setup, which it is.

When attempting to play music, the pulse seems to initialise but fails to play music and then either states device stopping, or gives an error code. I have attached a screen shots as these codes are varied. 

The settings are as suggested in the manual and guidance and my geek out works perfectly so i am beginning to worry that this may be a problem with the pulse itself.

The only way to get the display on the pulse to change is to change the format under audio midi setup on the mac. However it then usually reverts to 384k on atempting playback.

Can anyone suggest either the issue or start me on the path to a solution. I should add that it has been stable prior to this - I've had the pulse for about 5 months without an issue. I have also tried a spare usb cable and power cycled the unit.

Many thanks


3 people have this problem

I am having what appears to be the exact same issue.  I am on Windows though.  My issue started gradually and progressed to the point that I can't get my Xfi to initialize at all.  At first it would happen maybe once or twice a week and a power cycle would solve the issue.  That's no longer the case and it doesn't seem to matter what software I use or what driver I use (WASAPI or ASIO).  I tried multiple computers, multiple USB cables, and even reinstalled Windows to no avail.

I have an active support ticket on the issue.  Support told me they were familiar with the issue and stated that I should try booting up the Xfi without the USB cable plugged in, then waiting 5-10 seconds, and then plugging in the USB cable.  This didn't help in my situation so I'm still waiting on support to investigate further.

1 person likes this

Any update from support with a solution to this problem?  I am having same issue as described.

Hi there, this one was solved by flashing the firmware. After this the pulse worked as normal. I still occasionally have the same problem but seem to be able to sort the issue without refreshing. My process is (on my mac) 1. Select the pulse as the output sound device 2. Make sure the pulse is also selected in the midi control panel for sound and effects 3.Load Audionirvana and select the Pulse. Sometimes I have to repeat this as occasionally the sound output seems to default back to the inbuilt output.

1 person likes this

Thank you for your response Kevin.  How did you go about flashing the firmware for your Pulse? I am also using a Mac and do not have the DFU utility.  Did you just perform the flash using a Windows operating system before going back to use the Pulse with your Mac?  Again, thank you for your assistance.

Exactly as you describe. Flashed with a PC. The other thing that sometimes solves the problem is setting the output to pulse on the sound and midi options. Then starting up iTunes and getting it to play through iTunes. Then swap to my main audio player. Keep the sound window open as you might find that the output device keeps resetting to inbuilt on the Mac. Even after you've selected the pulse.

I am having almost the same problem with PC, however, it will work for a few seconds after PC boot up. Also Pulse will stop output anything if I adjust the volume with the knob. I am waiting for replies for my ticket.

 plug in with otg extension cable on the other dual usb end into a micro usb jack on android phone. It initialize the connection and the disconnect phone.  Works for me

I'm having the same issue on the Mac. 

Login or Signup to post a comment