Start a new topic
Solved

How do i unmute my Pulse?

My display says "muted" and I can't change it. Tried the obvious (using the volume control up/down) and powered down and back up, but nothing. Suggestions? There doesn't appear to be anything in the manual.


1 person has this problem

Pardon me, it says "mute"

Hmm, able to unmute by using the remote, but still, as it was all morning, no output, no matter what input is selected. Must have hit the unidentified mute button while desperately trying to get some audio out of it.  I'll open a ticket and see about getting it repaired.

If you haven't gotten this resolved, check out pressing the volume knob in and rotate.

My Pulse Standard does not have this, but the Pulse Infinity does.


When I connect the Apple Remote to the Pulse Standard, the center button mutes. This does not work on the Infinity

I have the same exact problem. Says MUTE; no way to change it; no sound.

Apple remote is the culprit!

My Geek Pulse Sfi only today changed into MUTE mode, and I have not used an Apple Remote on it for months.


How do I undo this MUTE ?

Got remote?

I just came across this thread because I have had the same problem with NO Apple remote connection. Except...even though the readout says, "Mute" I still get music. But...the volume cannot be modified up or down. (And yes I have selected "Knob Control" for the volume not USB.

What worked for me was to push the volume control knob in as suggested above. At first, one gets the choices of settings -- which doesn't help solve they 
problem. I continued to hold the knob for a few seconds; the choices vanished and sure enough -- without doing anything else -- "Mute" vanished from the display and the volume control knob could then be turned to reset the volume.

Login or Signup to post a comment