Start a new topic

Correct settings for J River Media Center.... PCM and DSD

I have been an advanced J River Media Center user since version 13....  now its on version 20.

Recently I acquired the geek out 450 and went through the hoops of  setting JRMC 20 on windows for correct operations that would allow PCM playback upto 32 bit 384 oversampling and DSD 64 and 128, with volume and mute control capability.

I am posting as this is probably an issue that has come up and will come up again by users.  The setting on OSX are basically the same.

 Here it goes...

On the TOP of JRMC20 main screen...

Go to tools menu......  Then option...   Then audio..   Audio device select lh labs geekout wasapi...   

There on device settings...  Under device only  open device for exclusive access and play a little silence on DOP stop  should be selected....   Bit depth should be 32 bit integer....   Buffering should be 100 miliseconds and not larger or the geek will start to click on audio like a dirt LP....   THEN SELECT Ok to get out of audio. 

Still in the options window... 
Down to settings.... Select bitstreaming : yes dsd......   

Then on DSP and output click to open the options.....  Select custom...  And then dsd....  And OK

Click DSP  &  output format...   This will open the DSP studio....  When it opens...  

NOW On the left click pane select output format.....   

Now on the right large pane....    Output encoding select none ( that way PCM will play on PCM format and DSD will play on DSD 1 bit format).....   

On channels  select source number of channels....   
On sample rate I have elected to resample every PCM to 384,000  you dont have to,  but to me they sound best that way....   To do it place the cursor pointer over the output colum...  Righr click there...  Select set all to 384,0000....   

If you do not want everything resampled like that , you can leave it or select individually by left clocking each input and selecting what you desire.... The one one you do need to change is....   

THIS IS IMPORTANT....Go to the last sample rate on the list....   "Greater than 384,0000"  ( all dsd are greater)  click it on the output column and set it to 176,400....  Then click the red x to close the pane.

Further down on settings menu...  

I have selected  play files from memory instead of disk and dissable display from  turning off ( that way if an hdmi display is off music can still play ( otherwise turning off the display will turn off the music,  its an hdmi protocl matter). 

Further down on volume select the option of system volume as the option. 


ON the control panel go to sound.....  

On the playback tab set MC as defafault..... 

On andvanced select allow apllication to take control of the device and give exclusive mode application priority...   Apply and OK. 


Thats the way I have it set and works great....   I hope it helps.....

JRMC20 is bit perfect, extremly flexible and extremly powerfull. The best I have seen. Interphase wise, the Theater mode, is bestted by Sooloos, but sound and flexibility wise JRMC is better ( not to mention cheper)

It further has other capabilities including the option to set the speakers distance and active DSP to correct the interaction with the room for better sound  taking into account the reverberation effect of the room the the sound the priduce,  but that another more advanced aspect...... 


1 person has this question

I have great results on this settings:

Audio Device: Geek Out HD Audio 1V5 [Kernel Streaming]

Tools>Audio Device>More>Geek Out HD Audio 1V5 [Kernel Streaming]

Device/Kernel Streaming Settings: A.) Bit Depth - 32 bit integer  B.) Volume - LH Labs Geek Out

Tools>Audio Device>Device Settings

DSP Audio Format/Output Encoding: 2xDSD in DoP Format

Tools>Settings>DSP and Audio Format>Output Encoding

Bitstreaming: Yes (DSD)


Play files from memory instead of disk: Ticked ( Yes)

I have found great enjoyment on the following settings:

Audio Device: Geek Out HD Audio 1V5 [Kernel Streaming]

Tools>Option>Audio>Audio Device>More>Geek Out HD Audio 1V5 [Kernel Streaming]

Device Settings:  A.) Bit Depth - 32 bit integer B.) Volume - LH Labs Geek Out

Tools>Option>Audio>Device Settings

Bitstreaming: Yes (DSD)


Grest. JRiver with Geekout is an amazing combo. When well setup is able to play everything and the sound quality is hard to beat at any price.

Thanks both - experimenting with JRiver and my Infinity with these settings. (Although I cannot find some of Michael's settings (Mac and MC21) - are they Windows specific? [Kernal Streaming & Kernal settings]

Those settings Michael referenced are Windows specific.

For a Mac, it is this:

Audio Device: Geek Pulse 1V2 Output [Core Audio]

Common-O to open Options, Audio > Audio Device> Geek Pulse 1V2 Output [Core Audio]

Device Settings: 

  • Open device with exclusive access
  • Integer Mode
DSP & output format
  • 2xDSD

Also Check out Player > Volume > Enable Volume when Bitstreaming.

I have not had good luck controlling volume with MC21 when the Pulse's volume control is set to USB.
I've got this to work well with Roon and Pure Music.

So far, there is not a single audio playback software that can do what I need it to do.

1 person likes this

OK, thanks! 

Do you alter the sample rates (and get it to upsample) at all? Jcintronlaw (above) advocated that - although I found it caused a crackling (like a record with a scratch) when I played .m4a (iTunes format) stuff.

I've tried both altering the sample rates and also using the settings that I have come to settle on.

I've done this both on Windows and Mac.

I don't have much history with JRiver MC, having started with v20, so it is quite possible that what I am using is a better choice for MC21 than it was for previous versions.

I find a lot of inconsistent behavior with all software that I have tried. I'm now convinced that if I want to switch from JRiver to Roon to Pure Music, I might as well reboot my system.

Leaving my DAC on 24x7 isn't a good idea either. For the most part, it is OK, but there have been times when it stopped responding to USB control of volume and stopped handling a change in resolution between source files


In these steps

ON the control panel go to sound.....

On the playback tab set MC as defafault.....

On andvanced select allow apllication to take control of the device and give exclusive mode application priority... Apply and OK.

Where can I find second step: set MC as ....

I am using Windows 10

Thank you




"On the playback tab set MC as defafault....."

That is a typo.

MC (JRiver Media Center) is not going to be listed here as a device.

The OP should have written that you should select your DAC as the default sound device.

Best regards,


Login or Signup to post a comment