Start a new topic

Geek Pulse X Ininity ... no sound

Dear community,

I own a Geek Pulse X Infinity (old chassis) since May 2015 and a LPS4. I was very satisfied with the DAC, however a few days ago the DAC stopped working. The pairing with my Mac via USB was no problem, however no music playback worked (I use Audirvana). Nor  could I change the sampling rate in the audio-midi-setup, it remained unchanged at 44,1 kHz, and also no output signal were provided by the DAC (I tried XLR to my amp, as every time, and also my headphone). I also tried a direct optical connection between my TV set and the DAC, however without any success, the speakers kept quiet.

I don't know what went wrong and what can I do. I hope you can give help me, especially, because I didn't receive any answer from the support until now (I wrote them a few days ago), despite of my prolongated warranty of two years.

For any hint thank you in advance.

Best regards

Stefan (from Frankfurt/Germany)

1 Comment

I have been filtering through the forums and came across your topic. It appears this has been resolved through the ticket system so I will go  ahead and mark this as resolved.
For the record, usually a firmware update to 2V0 resolves the following issue. This firmware can be obtained by opening a ticket and requesting for it.
- Matt


Login or Signup to post a comment