Start a new topic

pulse Xfi won't play music.

have a pulse Xfi which i have had recurrent problems with and sent in tickets due to the same issue. I use a Mac Pro running sierra (previously running earlier versions with the same issue). The pulse will not play sound. When connected via USB the pulse is visible in both sound options and the Audio Midi options on the mac. My start up process is to select the pulse in the sound menu and check it is also selected in the Audio Midi as the main sound output. I then try and get sound playing through iTunes - the on pressing play the pulse makes a buzzing sound through the headphones, this then stops and then no music plays. I cannot get it to play music via iTunes. I also have audiorivana v2 and this also does not work. On starting the programme the pulse is visible and selectable as an output. However, on trying to play music i get the same buzzing which then stops and either get one of two errors: 1. Cannot play via direct audio, please de-select this. I deselect it but it then cannot start audio device. 2. I get another random error code and no music plays. I have (as in previous tickets) flashed using a PC back to the latest firmware and this has still not solved the problem. I now have a pulse that i cannot use. Any suggestions welcome as i waited a long time for this pulse, am in the UK and am now worried i have an expensive black box sat in the UK that i cannot use. I have a go450 that works with both iTunes and Audiorivana on the same systems and software without problems.

1 person has this problem

Dear Kevin,

My Geek Pulse Signature DAC seems to be having similar issues as you're describing. It stopped working recently, having the same symptoms you're describing. I was wondering if you've resolved your issues? Was it hardware related? How did you solve it?

Kind Regards,


1 person likes this
I was sent an updated firmware for the pulse (Xfi), flashed successfully using a pc and it's been rock solid since and without problems.

1 person likes this

Awesome, this fixed it for me as well, contacted support, received v2.0 firmware for my Geek Pulse Signature. Works like a charm again.

This is Matt from the Tech Support team here at LH Labs. I have been filtering through the forums and have been trying to go through the ones that haven't been responded too and came across this one. The symptoms described above can indeed be resolved with a firmware update. I will go ahead and place the file below for future reference (if anyone else may be encountering a similar issue with their PULSE X-FI model!). The 'buzzing' is the ultimate sign that the Pulse needs that firmware update (: If the Pulse still however encounters similar symptoms after the update, then it would be best to open a ticket and we can go from there.




I think I may have the same problem with my Pulse Fi, Is this Firmware update suitable. I just have a concern that it isn't my issue because Linux now won't recognise the pulse at all now. Windows does seem to recognise it, but no sound comes out. If anyone has any insight into this I would be grateful. This is my second pulse. The first was faulty, and I don't want to brick this one. Thank you.

Hi @James Sellers
Thank you for reaching out. This issue was mainly common for the Pulse X models only as the Pulse FI had one ESS chip compared to the two that the X model had. (The firmware is different and a bit more complex as both channels are split between them). If Windows recognizes the Pulse and plays perfectly fine then all should be okay as the Pulse wasn't 100% Linux compatible. We advise that the user use the Pulse with either a Windows or Mac OS.
Thank you,
Matt L


This 2.0 Firmware fixed my X Fi.  Thank you for posting this!
I was worried by all the warnings about Batch specific firmware and the chance of bricking.
The firmware took smoothly and instantly started playing like it used to
I might try to use it more now that its not a gamble if it will work or not.  I've played more records recently because the xfi was being so damn flakey


OMG!! After years of my Pulse X Infinity intermittently not working, me getting very very frustrated, with tickets raised, it now works!

Thank you for posting this, a simple firmware upgrade is all that was required! Why they couldn't have told me this with a response to the ticket I raised is beyond me...

It sounds like a lot of other people are having this same issue, if they just told people about this firmware update I'm sure they could close a lot of tickets!

I feel there is a bit of confusion with the firmware numbers:

  • On the Pulse display itself, mine originally said "Main 2.0", whereas in the LH Control Panel it said "Geek Pulse X FI 1V5".
  • This firmware is stated as Version 2.0, this refers to the LH Control Panel version, NOT the Pulse display!
  • After upgrading, the pulse display now shows "Main 3.0" and the LH Control Panel now says "Geek Pulse X FI 2V0"

I hope this helps someone else, this has been a really frustrating experience for me, and has unfortunately done irreparable damage to my view of Light Harmonic as a company.



2 people like this

Hi LH Labs Technical Support Team,

Could you please confirm if the firmware you posted above is compatible with the Geek Pulse Signature Edition (V2 chassis). Also please confirm if the latest USB firmware is 1.0 and the latest MCU firmware is 1.27.

Thank you in advance.



I spoke too soon, I'm now experiencing dropout issue with the v2.0 firmware, as others are :(

At least it works for a bit now, so not totally useless! But randomly it just drops out and requires a reboot AND unplug/plug of the USB cable to get it working again!

Larry and LH Labs seem totally incompetent when it comes to actually producing a consumer product, seriously pissed off at this point, I've had nothing but trouble. But what do they care, they've got our money... :(


Join the (apparently very large) club, Matt. My pulse (mentioned in a post above) was sent with the wrong firmware - a year late, then had to be sent back to LH Labs to be repaired for a different issue. The repaired unit developed the issue again after a month or two. LH Labs did send me a brand new unit, so I guess there was some effort to get me working device, but that also developed a different fault. I found it in the attic the other day and the remembered the general feeling of anger and frustration that dealing with this company has managed to inspire in me. I will chuck it in the bin one day.

My advice is dump it and forget about it. I am now listening to a Yamaha network streamer. Cheaper, reliable, and sounds every bit as good.

Login or Signup to post a comment