Start a new topic

macOS Sierra does't recognize Pulse xfi.

My geek pulse, lps, or blue isn't working after i upgraded to El Capitain. I then upgraded to mac os sierra and nothing is working there either. I've tried this on two different computers and neither works. In the sound preference pane, the pulse shows up and disappears over and over again. When I select the pulse, it freezes itunes or whatever has sound playing, i.e.: browser, quick time, etc. 

 

As a side note, my geek out works on both computers, both os's no problem. 


Update: The Blue and LPS are working with macOS Sierra and El Captain. I'm powering the Blue with the LPS and obviously using Bluetooth from the Mac Pro to the Blue. 


The Pulse xfi definitely does not work with either of the os's. It doesn't work through the usb or optical out of the mac, directly connected to the pulse or through the usb of the LPS. 

I have the same issue with Geek Pulse on my iMac.  I see that this post is 11 days old and no resolution or status has been posted.  Is this just a forum for users or does LH Labs monitor and post responses?

I really don't understand why there isn't a mac os updater for the firmware. Or why on the website there isn't a better explanation as to why there isn't the current firmware available for download directly.

If LH Labs would have said that they weren't going to provide support for the mac os, I would have never bought this DAC. 

I am having  GPxfi>>>USB Mac Connection Problems. Today, GP will not stay connect to my Mac Pro at all.  Today, nothing is working to get sound out of the GPxffi.  One time it was connected, music palying but no sound from the GP on outputs or Hphone jack.  

What happens is the GPXfi just disappears from  the Mac's Audio Output Options.  (Yes, Sleep has been turned off per previous LH Support Ticket).   

This has been happening since day 1 but has the frequency of occurrence has increased. I am running  El Cap10.11.6 (15G1004) on a Mac Pro with the GeekPerfect app and Itunes.  

What has worked in the past:
Reboot in order of progression when previous reboot didn't help.  


1 GP reboot only
2  GP+LP4 reboot
3  GP/LP4/Mac reboot
Occasionally, when doing the reboots, CONSTANT LOUD CLICKING would be heard from the speakers after the amp was turned back on sending me lunging for the amp power switch in an effort to save tweeters and woofers.  This potentially Speaker Driver Killer CLICKING would persist until another reboot off GP/LPS4.  

Is anyone else experiencing this? 

________________________________________________________________________
System:    Mac Pro El Cap+GeekPerfect App + iTunes>>>>LH dual head USB to both LPS4.. AND GPXfi>>>>>Wireworld Eclipse>>>Passive Deluxe Line Drive Preamp>>>>>>Pass Labs Aleph 3 amp>>>>>>Audio Physic Step SLE Signature Mini Monitors          Grado RS2 and OPPO PM3 Headphones
________________________________________________________________________

Hello. For your info My Pulse Xfi infinity  works seamlessly on iMac using Sierra using iTunes as a player . It is connected directly to one of the back USB ports of the iMac. It worked the same way under El Capitan. 


I'm listening to it right now. 


I made a total clean install from scratch with these two oS.


I will now experiment with lps4 and other players. If I notice something, I will keep everybody posted.


Arnaud



I've just setup the lps4 with the pulse Xfi infinity on my Mac and it works also seamlessly. so it should work also for you. Brgds, Arnaud


Hello, Arnaud here. I have a hint for you. The Xfi infinity doesn't work for me with Sierra when I use directly one of the iMac's back USB port to connect to the geek pulse or the geek pulse plus lps4, to the pulse's usb source in port (usb male B) but does work when I use a self powered usb 3.0 hub connected to one of the iMac's back USB ports and then to the Pulse's USB male B Usb source in . I hope this will help you in troubleshooting what might be the problem for you. 

Brgds,Arnaud



Hi Arnaud, 


I had the opposite problem with powered usb hub and the geek pulse. My pulse wouldn't work unless the usb was directly plugged into the mac pro. 


A clean instal of the either mac os's would be nice to try, but I'm a working professional that needs my machines to be up and running. It's also kinda of a crazy thing to have to do just to get usb drivers to work with the Pulse. The bigger issue is LH Labs not having a mac installer for firmware updates. It would also be helpful if LH Labs hired more people to staff their support ticket system. The response time leaves a bit to be desired. 

I fully agree with you,Michaël.. LH labs is quite disappointing as regards mac support with the lack of the firmware updater sine months. The ticket answering leaves much to be desired also not talking of the evident lack of transparency and information flow regarding the other products some of us have been waiting for now it seems for ages: wave and source. I've just got my goV2+ infinity and once again it took ages. One thing I would even more appreciate is that the instruction manuals for their products could be downloadable and printable PDF files as it seems they can only be viewed online. It would also be interesting that already known buyers received direct mail from them regarding possible upgrades,trade ins....like other manufacturer do.
Michaël, i also get the impression that nobody from LH monitors or answers here our questions.This is a real letdown!! Regarding your problem, i would be surprised if all this has to do with the clean install, I think more of the built in USB controller in either the pro and or the pulse as a friend having both a Mac mini and the lps4 Geek pulse couple and having not performed the clean install is also not facing this problem even while using the ports at the back of the Mac mini. Could'nt it have something to do with the fact that some ports of the MacPro and my iMac are first driven by a usb3 contrôler and that the Go one's are only fully USB 2.0 compliant? Using the powered USB 3.0 hub would substitute another more flexible contrôler managing to "talk" to the Go one. Nevertheless this should now be addressed and solved by LH in a quickly coming firmware upgrade and be the launching time of the Mac firmware updater as well. Brgds,Arnaud

I like your thinking on the USB 2.0 port / hub. I forgot to mention that I have a LPS 4, so that should take care of the USB 2.0 interface. 

Login or Signup to post a comment